Manorrock.com / Online / Wiki Login

Websphere7

Edit

Even though Websphere 7 does not formally support JSF 2.0 you can get it to work in a degraded mode. Follow the steps below to get it to work on your version of Websphere 7.

  1. Upgrade to at least version 7.0.0.13
  2. Ship the Mojarra JAR files in your WEB-INF/lib directory
  3. Set the WAR classloader to PARENT_LAST
  4. Set the EAR classloader to PARENT_LAST and APPLICATION

Note the degraded mode means you are NOT going to be able to use @Resource or any JPA annotations. If you think you need support for it contact your IBM representative.

Note it will process @PostConstruct and @PreDestroy.

MainPage

Copyright © 2002-2014 Manorrock.com. All Rights Reserved.